Talks Add-on for The Events Calendar

Description

Add multiple talks to your single event without a hassle.

Creating multiple talks have never been easier. Create you event, set the desired number of days and a blank template will be created for you! All you need to do is add the image to your talk, title, description, time, location and speaker and you’re done.

Add a simple shortcode of your talk anywhere on your page, including a simple and extended widget that you can use in your theme.

** Created using the best coding practices and latest standards **

Screenshots

  • A clean event has no event talks, because you need to enter the details of your event.
  • After creating the event fill your talks with content. You can change the title of the day tabs as well 😉
  • This is how it looks like on the front end of the event page, if you've placed the shortcode in it.
  • If you want to show your talks on a separate page, feel free to add the shortcode there.
  • Adding shortcode is easy - it's embedded in the TinyMCE editor. Just click on the button, and select the talk you want to display. Classes are optional.
  • If you want to place your talk in a widget you can do that as well, choose what you want and you're good to go.

Installation

Install & Activate

Installing the plugin is easy. Just follow these steps:

Installing from WordPress repository:

  1. From the dashboard of your site, navigate to Plugins –> Add New.
  2. In the Search type Talks Add-on for The Events Calendar
  3. Click Install Now
  4. When it’s finished, activate the plugin via the prompt. A message will show confirming activation was successful.

Uploading the .zip file:

  1. From the dashboard of your site, navigate to Plugins –> Add New.
  2. Select the Upload option and hit “Choose File.”
  3. When the popup appears select the talks-add-on-for-events-calendar-plugin.x.x.zip file from your desktop. (The ‘x.x’ will change depending on the current version number).
  4. Follow the on-screen instructions and wait as the upload completes.
  5. When it’s finished, activate the plugin via the prompt. A message will show confirming activation was successful.

That’s it! create a new event, set the talks in your Event Talks metabox and place the [event-talks] shortcode wherever you want, or set up the widget on your page.

Requirements

  • PHP 5.2.4 or greater (recommended: PHP 5.4 or greater)
  • WordPress 3.9 or above
  • jQuery 1.11.x

FAQ

Installation Instructions

Install & Activate

Installing the plugin is easy. Just follow these steps:

Installing from WordPress repository:

  1. From the dashboard of your site, navigate to Plugins –> Add New.
  2. In the Search type Talks Add-on for The Events Calendar
  3. Click Install Now
  4. When it’s finished, activate the plugin via the prompt. A message will show confirming activation was successful.

Uploading the .zip file:

  1. From the dashboard of your site, navigate to Plugins –> Add New.
  2. Select the Upload option and hit “Choose File.”
  3. When the popup appears select the talks-add-on-for-events-calendar-plugin.x.x.zip file from your desktop. (The ‘x.x’ will change depending on the current version number).
  4. Follow the on-screen instructions and wait as the upload completes.
  5. When it’s finished, activate the plugin via the prompt. A message will show confirming activation was successful.

That’s it! create a new event, set the talks in your Event Talks metabox and place the [event-talks] shortcode wherever you want, or set up the widget on your page.

Requirements

  • PHP 5.2.4 or greater (recommended: PHP 5.4 or greater)
  • WordPress 3.9 or above
  • jQuery 1.11.x

Suradnici i Programeri

“Talks Add-on for The Events Calendar” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.0.0

  • Initial Release 30 June 2016

1.0.1

  • Changed the readme.txt to correctly display screenshots on wordpress.org plugin repository

1.0.2

  • Tested with WordPress 4.6 to ensure compatibility

1.0.3

  • Tested with WordPress 4.7 on Twenty Seventeen theme with Talk Events ver. 4.3.3 to ensure compatibility

1.0.4

  • Tested with WordPress 4.8 on Twenty Seventeen theme with Talk Events ver. 4.5.4 to ensure compatibility